【通达信最新手机版】通达信冠军一号顶级私募专用指标,全国独家发布源码放送

发布时间:2019-06-14 来源:股票 点击: 当前位置:首页 > 行业 > 股票 > 【通达信最新手机版】通达信冠军 手机阅读

【feedingms.com - 行业】

股票公式不明白请查阅:股票公式文件使用以及说明!

通达信冠军一号顶级私募专用指标,全国独家发布源码放送

通达信冠军一号顶级私募专用指标,全国独家发布
{原文链接:http://www.guhai.com.cn/html/GS/tong-da-xin/25314.html}

冠军一号顶级私募专用指标,可惜是加密的,现在发布源码放送,供大家交流学习,若有冒犯,请海涵
 以下是副图源码
 
多止损:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5,LINETHICK0,COLORYELLOW;
 多止盈:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK0,COLORWHITE;
 空止损:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5+XMA(XMA(H,25),25),LINETHICK0,COLORYELLOW;
 空止盈:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK0,COLORWHITE;
 短高H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
 +13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
 +7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
 REF(H,20))/210,COLORBLUE,LINETHICK1;
 短低L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
 +13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
 +7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
 REF(L,20))/210,COLORBLUE,LINETHICK1;
 D90H:=EMA(短高H,90),COLORRED,LINETHICK1;
 D90L:=EMA(短低L,90),COLORRED,LINETHICK1;
 D90差:=D90H-D90L;
 D90顶:=D90H+D90差*2,COLORRED,LINETHICK1;
 D90底:=D90L-D90差*2,COLORRED,LINETHICK1;
 高0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;
 低0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;
 多头定位:=低0>=D90底 AND 高0>=D90顶;
 空头定位:=高0<=D90顶 AND 低0<=D90底;
 震荡定位:=低0>=D90底 AND 高0<=D90顶;
 短顶:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2+XMA(XMA(H,25),25),LINETHICK2,COLORGREEN;
 短底:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2,LINETHICK2,COLORGREEN;
 短线收盘:=(C-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
 短线开盘:=(O-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
 短线高盘:=(H-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
 短线低盘:=(L-短底)/(短顶-短底)*100000,LINETHICK0,COLORRED;
 
顶1:=110000,COLORYELLOW,LINETHICK0;
 底1:=-10000,COLORYELLOW,LINETHICK0;
 
STICKLINE(多头定位=1,顶1,底1,5,0),COLOR000066;
 STICKLINE(空头定位=1,顶1,底1,5,0),COLOR003300;
 STICKLINE(震荡定位=1,顶1,底1,5,0),COLOR555555;
 
震荡顶:=(XMA(XMA(短线高盘,25),25)-XMA(XMA(短线低盘,25),25))*1+XMA(XMA(短线高盘,25),25),DOTLINE,COLORWHITE;
 震荡底:=XMA(XMA(短线低盘,25),25)-(XMA(XMA(短线高盘,25),25)-XMA(XMA(短线低盘,25),25))*1,DOTLINE,COLORWHITE;
 
做空:80000,COLORWHITE,LINETHICK1;
 做多:20000,COLORWHITE,LINETHICK1;
 空损:110000,COLORMAGENTA,LINETHICK2;
 多损:-10000,COLORMAGENTA,LINETHICK2;
 
DRAWTEXT(ISLASTBAR,108000,"顶"),COLORMAGENTA;
 DRAWTEXT(ISLASTBAR,80000,"卖"),COLORGREEN;
 DRAWTEXT(ISLASTBAR,20000,"买"),COLORRED;
 DRAWTEXT(ISLASTBAR,-9000,"底"),COLORMAGENTA;
 
BSB:=EMA((CLOSE+HIGH+LOW)/3,3);
BSM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),POINTDOT,COLORYELLOW;   
STICKLINE(BSB>=BSM,短线低盘,短线高盘,0.0,0),COLORRED;
STICKLINE(BSB>=BSM,短线收盘,短线开盘,3,1),COLORRED;
 STICKLINE(BSB<=BSM,短线低盘,短线高盘,0.0,0),COLORGREEN;
STICKLINE(BSB<=BSM,短线收盘,短线开盘,3,1),COLORGREEN;
 
白色点多定位1:=短线低盘<做多 AND 短线高盘>做多;
 白色点空定位1:=短线高盘>做空 AND 短线低盘<做空;
 STICKLINE(白色点多定位1=1,短线低盘,做多,3,0),COLORWHITE;
STICKLINE(白色点空定位1=1,短线高盘,做空,3,0),COLORWHITE;
白色点多定位2:=短线高盘<做多;
 白色点空定位2:=短线低盘>做空;
 STICKLINE(白色点多定位2=1,短线低盘,短线高盘,0.0,0),COLORWHITE;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,3,0),COLORWHITE;
 STICKLINE(白色点空定位2=1,短线低盘,短线高盘,0.0,0),COLORWHITE;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,3,0),COLORWHITE;
 多头多定位:=CROSS(做多,短线低盘) AND 多头定位=1;
 多头平定位:=CROSS(短线高盘,做空) AND 多头定位=1 AND 震荡定位=0;
 空头空定位:=CROSS(短线高盘,做空) AND 空头定位=1;
 空头平定位:=CROSS(做多,短线低盘) AND 空头定位=1 AND 震荡定位=0;
 震荡多定位:=CROSS(做多,短线低盘) AND 震荡定位=1;
 震荡空定位:=CROSS(短线高盘,做空) AND 震荡定位=1;
 DRAWICON(空头平定位=1,短线低盘,3);
 DRAWICON(多头平定位=1,短线高盘,4);
 DRAWICON(多头多定位=1 OR 震荡多定位=1,短线低盘,3);
 DRAWICON(空头空定位=1 OR 震荡空定位=1,短线高盘,4);
 

以下是主图源码:
 HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
 +13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
 +7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
 REF(H,20))/210,COLORBLUE,LINETHICK1;
 LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
 +13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
 +7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
 REF(L,20))/210,COLORBLUE,LINETHICK1;
 D90H:=EMA(HH,90),COLORRED,LINETHICK1;
 D90L:=EMA(LL,90),COLORRED,LINETHICK1;
 DGH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
 +13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
 +7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
 REF(H,20))/210,COLORBLUE,LINETHICK1;DDL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
 +13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
 +7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
 REF(L,20))/210,COLORBLUE,LINETHICK1;D90C:=D90H-D90L;D90D:=D90H+D90C*2,COLORRED,LINETHICK1;D90T:=D90L-D90C*2,COLORRED,LINETHICK1;G0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;D0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;DTD:=D0>=D90T AND G0>=D90D;KTD:=G0<=D90D AND D0<=D90T;ZDD:=D0>=D90T AND G0<=D90D;BDD0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60),LINETHICK2,COLORGREEN;BDT0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3,LINETHICK2,COLORGREEN;STICKLINE(DTD=1,G0,D0,5,0),COLOR000066;STICKLINE(KTD=1,G0,D0,5,0),COLOR003300;STICKLINE(ZDD=1,G0,D0,5,0),COLOR555555;
 ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORWHITE;
 ZD1:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,DOTLINE,COLORWHITE;
 STICKLINE(1=1,D90H,D90L,5,0),COLORLIGRAY;
 HD:=DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),HHV(HIGH,4),1),LINETHICK2,COLORMAGENTA;
 HK:=DRAWLINE(LOW<=LLV(LOW,20),LOW,HIGH>=HHV(HIGH,20),LLV(LOW,4),1),LINETHICK2,COLORWHITE;
 BSB:=EMA((CLOSE+HIGH+LOW)/3,3);
BSM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),POINTDOT,COLORYELLOW;   
STICKLINE(BSB>=BSM,LOW,HIGH,0.0,0),COLORRED;
STICKLINE(BSB>=BSM,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(BSB<=BSM,LOW,HIGH,0.0,0),COLORGREEN;
STICKLINE(BSB<=BSM,CLOSE,OPEN,3,1),COLORGREEN;
 白色点多定位1:=L<ZD1 AND H>ZD1;
 白色点空定位1:=H>ZK1 AND L<ZK1;
 STICKLINE(白色点多定位1=1,L,ZD1,3,0),COLORWHITE;
STICKLINE(白色点空定位1=1,H,ZK1,3,0),COLORWHITE;
白色点多定位2:=H<ZD1;
 白色点空定位2:=L>ZK1;
 STICKLINE(白色点多定位2=1,L,H,0.0,0),COLORWHITE;
STICKLINE(白色点多定位2=1,C,O,3,0),COLORWHITE;
 STICKLINE(白色点空定位2=1,L,H,0.0,0),COLORWHITE;
STICKLINE(白色点空定位2=1,C,O,3,0),COLORWHITE;
 多头多定位:=CROSS(ZD1,L) AND DTD=1;
 多头平定位:=CROSS(H,ZK1) AND DTD=1 AND ZDD=0;
 空头空定位:=CROSS(H,ZK1) AND KTD=1;
 空头平定位:=CROSS(ZD1,L) AND KTD=1 AND ZDD=0;
 震荡多定位:=CROSS(ZD1,L) AND ZDD=1;
 震荡空定位:=CROSS(H,ZK1) AND ZDD=1;
 DRAWICON(空头平定位=1,L,3);
 DRAWICON(多头平定位=1,H,4);
 DRAWICON(多头多定位=1 OR 震荡多定位=1,L,3);
 DRAWICON(空头空定位=1 OR 震荡空定位=1,H,4);
 
DRAWTEXT(ISLASTBAR,ZK1,"卖"),COLORGREEN;
 DRAWTEXT(ISLASTBAR,ZD1,"买"),COLORRED;
 

大单动向:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7);
 涨跌动因:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);
 大单差分:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);
 DDZ1:=大单差分*7;
 DDZ2:=大单差分*3;
 主力活跃度:=LARGEINTRDVOL-LARGEOUTTRDVOL;
 主力净流入:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*AMO/V/10000;
 买入力度:=LARGEINTRDVOL*100/VOL;
 卖出力度:=LARGEOUTTRDVOL*100/VOL;
 超B:=L2_AMO(0,2)/10000.0;
 大B:=L2_AMO(1,2)/10000.0;
 中B:=L2_AMO(2,2)/10000.0;
 小B:=L2_AMO(3,2)/10000.0;
 超S:=L2_AMO(0,3)/10000.0;
 大S:=L2_AMO(1,3)/10000.0;
 中S:=L2_AMO(2,3)/10000.0;
 小S:=L2_AMO(3,3)/10000.0;
 资金流向:=(超B+大B+中B+小B)-(超S+大S+中S+小S);
 资金选股:=资金流向>0 AND 大单动向>0 AND 涨跌动因>0 AND DDZ1>0 AND DDZ2>0 AND 主力活跃度>0 AND 主力净流入>0 AND 买入力度>卖出力度;
 STICKLINE(资金选股=1 AND (H-C)<(C-L),LOW,HIGH,0.0,0),COLORRED;
 STICKLINE(资金选股=1 AND (H-C)<(C-L),CLOSE,OPEN,3,0),COLORRED;
 
灰色线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*4+XMA(XMA(H,60),60),LINETHICK2,COLORGREEN;
 绿色线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*5+XMA(XMA(H,60),60),LINETHICK2,COLORGREEN;
 红色线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*6+XMA(XMA(H,60),60),LINETHICK2,COLORGREEN;
 冠军线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*7+XMA(XMA(H,60),60),LINETHICK2,COLORGREEN;
 DRAWTEXT(1=1 AND CURRBARSCOUNT=50,红色线,"【红色:多头趋势,顺势买卖】"),COLORRED;
 DRAWTEXT(1=1 AND CURRBARSCOUNT=50,绿色线,"【绿色:空头趋势,空仓观望】"),COLORGREEN;
 DRAWTEXT(1=1 AND CURRBARSCOUNT=50,灰色线,"【灰色:震荡趋势,投机买卖】"),COLORLIGRAY;

通达信冠军一号顶级私募专用指标,全国独家发布源码放送

 

本文来源:http://feedingms.com/hangye/98276/

推荐访问:

股票推荐文章

股票热门文章

股票扩展文章

本文相关推荐